易语言客户与服务器交互数据 客户和服务器连接怎么加密 例如 客户1.连接("127.0.0.1,

已举报 回答 关注
易语言客户与服务器交互数据 客户和服务器连接怎么加密 例如 客户1.连接("127.0.0.1,
问在线客服
扫码问在线客服
  • 回答数

    8

  • 浏览数

    3,331

8个回答 默认排序
  • 默认排序
  • 按时间排序

已采纳
易语言自带的组件对高并发本来支持就不好,客户上线后,需要上传密钥文本,在一定时间内,匹配才允许,不匹配,则主动断线
或者,直接取连接着的IP,如果一个IP链接量大于多少,直接断开即可
其实可以用光速的模块,解决起来会方便的多.
取消 评论
这个我完全不懂啊
取消 评论
'据我所知没有直接的方法~~但可以用以下方法实现
'=======判断连接状态时只要是否已连接逻辑变量为真则为连接状态否则是断开了连接!
.版本 2
.支持库 eSocket

.子程序 _按钮1_被单击

是否已连接 = 客户1.连接 (“127.0.0.1”, 19730)
是否已连接 = 异步套接字1.连接 (“127.0.0.1”, 80)

.子程序 _客户1_连接断开

是否已连接 = 假

.子程序 _异步套接字1_连接断开

是否已连接 = 假
================================
.版本 2

.子程序 发送数据

.如果 (客户1.发送数据 (123))
' 信息框 (成功发送!, 0, )
.否则
信息框 (“发送数据失败,请检查网络连接!”, 0, )
取消 评论
用数据报 这个就可以
取消 评论
要抓包吧?
取消 评论
自己写俩软件 一个建个服务器组件 一个是客户端组件
客户端连接上服务器以后 发送数据 最前面加个标识符 比如前面加个Y是用户名 M是密码
然后服务器收到数据以后 判断以下收到的数据取文本最前面标识符是什么 然后相应自己写出到一个TXT文件里保存
以此类推 以这种发送封包然后服务器判断封包标识符来保存这些数据
服务器最后再加上 判断客户端登录的帐号 然后发送数据 也是用封包传送 等级 物品 金钱之类的东西 客户端登录成功以后 通过服务器来获取这些信息
如果你觉得麻烦的话直接保存到他本地的文件里 写配置项然后加密 保存到C盘他一般找不到的地方 然后每次打开的时候读取本地保存的配置项就可以了
取消 评论
要公网IP才可以,最好不要在路由器下面,如果在路由器下面要做端口映射
取消 评论
用WED命令连接服务器
取消 评论
ZOL问答 > 三脚架 > 其他分类 > 易语言客户与服务器交互数据 客户和服务器连接怎么加密 例如 客户1.连接("127.0.0.1,

举报

感谢您为社区的和谐贡献力量请选择举报类型

举报成功

经过核实后将会做出处理
感谢您为社区和谐做出贡献

扫码参与新品0元试用
晒单、顶楼豪礼等你拿

扫一扫,关注我们
提示

确定要取消此次报名,退出该活动?