在VLAN中怎么划分和设置各个网关

已举报 回答 关注
在VLAN中怎么划分和设置各个网关
问在线客服
扫码问在线客服
  • 回答数

    4

  • 浏览数

    5,342

4个回答 默认排序
  • 默认排序
  • 按时间排序

已采纳
创建:switch(config)#vlan 10
switch(config-vlan)#name maomao
进入端口将其划如VLAN
switch(config)interface f0/2
switch(config-if)#switchport access vlan 10
将多端口加入VLAN
switch(config)# interface range f0/1 – 5
switch(config-if-range)#switchport access vlan 10
设置网关就是给你所划入VLAN的端口分配IP地址
switch(config)interface f0/2
switch(config)ip address 192.168.1.5 255.255.0.0
switch(config)no shutdown
取消 评论
对于vlan的划分你需要事先考虑好按照什么要求划分。还有每个vlan里面有多少台机器,每个vlan里面的安全性要求以及主要是数据传出还是上网之类的要求。。才可以划分的。而且你提问的是划分的命令还是理论上划分的要求呢?
取消 评论

TTK

做单臂路由吧:
1、路由器上开子接口
2、设子接口IP,即网关
3、绑定对应VLAN
如:
interface Ethernet0/1.1
vlan-type dot1q vid 20
ip address 192.168.2.1 255.255.255.0

interface Ethernet0/1.2
vlan-type dot1q vid 30
ip address 192.168.3.1 255.255.255.0

另外,主接口IP可以去掉。交换机与路由器所连接口要设为TRUNK。

_______________________________________________________
H3C的设备用得不多,刚才去查了了,S3600V2是三层交换机,那么建议你直接在交换机上做VLAN间路由:
vlan 2

port g1/0/13 to g1/0/18
quit
int vlan 2
ip add 192.168.2.1 24

vlan 3
port g1/0/19 to g1/0/24
quit
int vlan 3
ip add 192.168.3.1 24

然后,加一条静态默认: ip route-static 0.0.0.0 0.0.0.0 192.168.1.1

路由器上两条静态路由:ip route 192.168.0.0 255.255.0.0 192.168.1.2(与路由器相连的IP)
ip route 0.0.0.0 0.0.0.0 ISP的对端IP

路由器上需要配NAPT:
比如
acl number 3000
rule 3000 permit ip
int g0/0(你的WAN口)
nat outbound 3000
这样你的局域网内的电脑都可以上外网。
取消 评论
下面以创建VLAN 10的IP地址为192.168.1.1/24为例来说明其配置过程:
在路由器的全局配置模式下创建VLAN 10,命令为Router(Config)#vlan 10
进入VLAN接口模式,命令为Router(Config)#int vlan 10
在接口VLAN接口配置模式下配置其IP地址,命令为Router(Config-if)#ip add 192.168.1.1255.255.255.0
取消 评论
ZOL问答 > 防毒及邮件过滤 > 其他分类 > 在VLAN中怎么划分和设置各个网关

特惠推荐

  • 天融信TopGate 500

    天融信TopGate 500

    参考价:价格面议    评分:-

    热门排行榜:第1名

  • 京东搜一搜

热门防毒及邮件过滤排行

查看更多排行 >

举报

感谢您为社区的和谐贡献力量请选择举报类型

举报成功

经过核实后将会做出处理
感谢您为社区和谐做出贡献

扫码参与新品0元试用
晒单、顶楼豪礼等你拿

扫一扫,关注我们
提示

确定要取消此次报名,退出该活动?