各位大佬,为何我vs2017输出中文乱码

已举报 回答 关注
各位大佬,为何我vs2017输出中文乱码
问在线客服
扫码问在线客服
  • 回答数

    7

  • 浏览数

    1,132

7个回答 默认排序
  • 默认排序
  • 按时间排序

已采纳
你用notepad++打开,全选你的代码,然后选编码这样试试,我用Qt也经常遇到这个问题,但vs2017我不知道行不行,你可以试试

取消 评论
在TOMCAT中的server.xml中的
<Connector中添加两个设置useBodyEncodingForURI="true" //设置POST和GET使用相同编码
URIEncoding="UTF-8" //对URI使用utf-8编码处理
?
<Connector useBodyEncodingForURI="true" URIEncoding="UTF-8"connectionTimeout="20000" maxThreads="150" port="8888" protocol="HTTP/1.1" redirectPort="8443"/>
取消 评论
用的什么编译器?改一下编码方式试试
取消 评论

mwj

你设置一下myeclipse中的tomcat编码格式

取消 评论
一个逻辑错误
flag最开始没有赋值,这样没法判断
if(str[i]!='0')
{
if(flag==1)
{
就是这里,flag第一次运行时没有赋值的

根据中文习惯,这个零是很难处理的,在不同的位置,有不同的读法,你要好好归纳一下,在写程序
基本的思路就是处理连续的零,其他的好处理
i是8,打印 亿,i是4,打印 万
print_digit(str[i]);
if(i%4==3) printf("千");
if(i%4==2) printf("百");
if(i%4==1) printf("十");
这一块没问题

设置flag是正确的思路。打印零的时候,要判断下一位是否还是零,要是下一位是零,则这个不打印

基本的思路是对的
反序直接用系统函数strrev就可以,不用自己在写相应的功能函数。呵呵
取消 评论
编码的问题,保存为unicode吧
取消 评论
代码的字符集可以选择在head部分加入<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />试试
取消 评论
ZOL问答 > 电源 > 其他分类 > 各位大佬,为何我vs2017输出中文乱码

举报

感谢您为社区的和谐贡献力量请选择举报类型

举报成功

经过核实后将会做出处理
感谢您为社区和谐做出贡献

扫码参与新品0元试用
晒单、顶楼豪礼等你拿

扫一扫,关注我们
提示

确定要取消此次报名,退出该活动?