怎么设置linux里的vim编辑器颜色

已举报 回答 关注

怎么设置linux里的vim编辑器颜色

  • 回答数

    10

  • 浏览数

    1,507

10个回答 默认排序
  • 默认排序
  • 按时间排序

已采纳
:colorscheme 颜色方案名
直接使用内置颜色方案
取消 评论
推荐使用phpexcel功能很强大,我一直用这个
取消 评论
vim ~/.vimrc然后自己设置一下主题 不把括号 的颜色改变了,还真不知道怎么单纯改一下括号的颜色。
colorscheme desert ::这个是设置为沙漠主题另外你也可以自己去网上下载一些好的主题 然后类似下面的操作安装新的主题
安装:
$ cd vim-colors-solarized/colors$ mv solarized.vim ~/.vim/colors/
然后在 ~/.gvimrc 文件中添加以下几行命令
syntax enableset background=darkcolorscheme solarized
取消 评论
  在你的主目录下建一个文件 .vimrc :
  vi ~/.vimrc
  syntax on

  保存退出。
  
  再用vim编辑源代码,就可以看到效果了。比如 vim test.c。
取消 评论
  在/etc/vim/vimrc中增加如下一句:
  highlight Comment ctermfg=green guifg=green
取消 评论
vim /etc/resolv.conf这里的配置网卡的dns
可以再加一条
nameserver 192.168.0.1
nameserver 8.8.8.8
取消 评论
致的, 因为你从数据提取的是gbk的, csv文件可能不支持gbk编码

英文系统下的字体可能不存在, 你用什么查看这个文件的,设置文件查看器的编码
取消 评论
因为要写脚本 使用vi编辑器必然不太友好,不会有颜色区分和显示内容,好吧,就选择使用vim 可是遇到颜色调试的问题,周折了很久才搞定。分享一下哈

环境一:直接登录linux(cent5.X cent6.X)系统(前提你安装了vimp这个编辑器软件)
问题:vim fimename #vim编辑文件的时候编辑的字符只有一种颜色,正常来说应该不同的语法成分会有不同的颜色呈现。
解决方法:
可能原因:
[root@gjlin init.d]# vi /etc/vimrc #编辑这个文件加入“syntax on” 这一行字符串。(如果有查看是否否被注释掉了,把注释去掉即可)

环境二:使用SSH工具我使用的是SecureCRT这个软件连接到linux系统的。
问题:vim fimename #vim编辑文件的时候编辑的字符只有单一颜色,正常来说应该不同的语法成分会有不同的颜色呈现。
解决方法:
1、首先按照环境一的方法检查一下,如果环境一的情况不在进行第二步。
2、修改终端TERM这个环境变量:
1)export命令 临时生效
[root@gjlin init.d]# echo $TERM
xterm
#如果结果显示:非“xterm”执行如下命令
[root@gjlin terminfo]# export TERM=xterm <------------使用export命令声明,变量在关闭shell时失效(临时)
2)修改配置/etc/profile
[root@gjlin tmp]# vim /etc/profile
export TERM=xterm <------------------增加此行即可。保存退出。
#想要马上生效就要运行以下命令
[root@gjlin tmp]# source /etc/profile 《--------------加载一下配置文件,否则下次登录时才会生效。
注:如果第2步还未是没有解决问题进行第三步。
3、设置CRT。
options -->Session Options -->Terminal-->Emulation中将Terminal下拉菜单选xterm然后将必须钩上ANSI Colour
取消 评论
加载全部10个答案 加载中...
ZOL问答 > 怎么设置linux里的vim编辑器颜色

举报

感谢您为社区的和谐贡献力量请选择举报类型

举报成功

经过核实后将会做出处理
感谢您为社区和谐做出贡献

提示

确定要取消此次报名,退出该活动?