易语言 网页浏览器,点击链接直接下载怎么实现

已举报 回答 关注
易语言 网页浏览器,点击链接直接下载怎么实现
问在线客服
扫码问在线客服
  • 回答数

    2

  • 浏览数

    1,647

2个回答 默认排序
  • 默认排序
  • 按时间排序

已采纳
.版本 2
.支持库 HtmlView
.支持库 internet
.子程序 _超文本浏览框1_即将跳转, 逻辑型
.局部变量 扩展名, 文本型
扩展名 = 到小写 (取文本右边 (超文本浏览框1.地址, 4))
.如果 (扩展名 = “.rar” 或 扩展名 = “.zip” 或 扩展名 = “.apk”)
下载 (超文本浏览框1.地址)
返回 (假)
.否则
返回 (真)
.如果结束

.子程序 下载
.参数 URL, 文本型
.局部变量 字节集, 字节集
.局部变量 文件名, 文本型
文件名 = 取文本右边 (URL, 取文本长度 (URL) - 倒找文本 (URL, “/”, , 真))
输出调试文本 (“DOWN:” + URL + “ -> ” + 文件名)
字节集 = HTTP读文件 (URL)
写到文件 (“C:\” + 文件名, 字节集)
取消 评论
在迅雷官网下载mac迅雷就可以了
取消 评论
ZOL问答 > 易语言 网页浏览器,点击链接直接下载怎么实现

举报

感谢您为社区的和谐贡献力量请选择举报类型

举报成功

经过核实后将会做出处理
感谢您为社区和谐做出贡献

扫码参与新品0元试用
晒单、顶楼豪礼等你拿

扫一扫,关注我们
提示

确定要取消此次报名,退出该活动?